Announcement

Announcement Module
Collapse
No announcement yet.

X-Charge Errors after upgrading Liberty to 3.6a

Page Title Module
Move Remove Collapse
This is a sticky topic.
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Support Team
    started a topic X-Charge Errors after upgrading Liberty to 3.6a

    X-Charge Errors after upgrading Liberty to 3.6a

    As of Liberty4 version 3.6a, credit card processing is handled a little differently. We still utilize X-Charge but in order to be PCI Compliant, Liberty now needs the following to be in place:

    - X-Charge version 7.0.2 or above
    - XCClient.dll Installation Program (which is version7.0.2b5 as of 12/7/2009)

    Resaleworld's Developers worked closely with X-Charge to make this integration possible. X-Charge's preferred method of PCI Compliance is done via the XCClient utility. It's not enough to have the latest version of X-Charge installed. Since Liberty is using X-Charge's preferred method of integration (the XCClient utility), one MUST have this installed.

    If both of the above are NOT installed, any number of errors/issues will ensue.

    For example, if one installs the latest version of X-Charge but fails to install the XCClient utility, the following error will appear when you go to Setup > Setup Credit Card Link > Configure XCharge.



    As you can see, errors and the unexpected WILL occur if you do not have each of these modules in place. If you speak with a X-Charge representative that appears unable to help you or insists that Resaleworld "knows how to do this," please escalate your call to a supervisor with X-Charge. Both downloads are available from X-Charge and Liberty only functions for credit cards if BOTH OF THESE are in place. This is coming directly from X-Charge. Also, this is a new release, so each and every person at X-Charge might not be aware of these changes. We're working very closely with X-Charge to ensure that both vendors are on the same page.

  • tcstrub2
    replied
    working on this upgrade today and I have additional for dealing with a terminal services environment. XCClient.dll Installation Program not only needs to be installed on the terminal server, it also needs to be ran under each profile that logs on to the terminal server.

    Leave a comment:

Working...
X