Announcement

Announcement Module
Collapse
No announcement yet.

Unable To Connect To Database

Page Title Module
Move Remove Collapse
This is a sticky topic.
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable To Connect To Database

    This error will come up if Liberty cannot connect to and successfully communicate with the MS SQL Server database engine. Important things to consider:

    - When Liberty is installed, one MUST select "Server" on the first installation/computer that is being designated as the database server. If there will only be one computer, then it is the server. Selecting "Client" will result in this error, since there is no MS SQL Server to connect to.

    - Firewalls, security, et al can block a stand-alone computer OR network workstations from connecting to the server. Make sure all programs have been properly configured. For troubleshooting, disable all security (temporarily) and see if the connection works. If so, contact your security software provider for assistance with your security product.

    - Name resolution. Your computers must be able to resolve computer names. A workstation would connect to server (if server was your server's name). If this is a new installation, you would point your workstations to server\Liberty, as we now perform a named instance installation of MS SQL Server

    - You have a non-named instance server (installed from Liberty 2002 or a L4C installation prior to 3.5a) and thus, your MS SQL Server shows just server for the server name. You then went to add a new workstation to the network using an installer version 3.5a or above, which is trying to A) connect to server\Liberty and B) is trying to pass through a new/different password to the server. This is a Known Issue outlined within My Resaleworld. It's also VERY easy to fix. 1) visit HKEY_LOCAL_MACHINE\SOFTWARE\ResaleWorld.com\RWD\Da tabase in the Registry and you'll find the password (DBPassord) starts with a 6. Visit the same key on the workstation, and you'll find it starts with a 5. Copy/paste that key OR log in to My Resaleworld and view our FAQ entry under Installation Issues for a patch (I don't want to post that out here for fear of someone executing it when it's not need, thus, breaking their system).

    One of the big questions to ask is, "has this ever worked?" If you were able to connect yesterday but can't today, something has changed. Security? Physical connection? If it's never worked though, chances are it's one of the installation issues outlined above.

    This is a 'starter' thread and we'll keep it posted as new issues/findings come up.
    Resaleworld Support

    ***Don't forget to search the forum first! There might already be a post that resolves your issue!***

  • #2
    Unable to Connect to Database

    Dean I'm reading the posts on this issue. All of a sudden I couldn't access database. Order manager was working and POS.
    I see info on DBPassword's bing different, but I don't see this on my Windows Registry.
    I've uninstalled Liberty, reinstalled, and still can't get this password issue fixed.
    When I open RWD program file, I don't see the DBPassword info at all...
    I need some additionl info to over come this can not connect to datbase issue I've suddenly developed.

    Thanks for any pointers.

    suzonne

    Comment


    • #3
      Hmmm, Point of Sale and Order Manager would launch? That's not making much sense.

      Let's start at the beginning:

      - How many computers do you have?
      Resaleworld Support

      ***Don't forget to search the forum first! There might already be a post that resolves your issue!***

      Comment


      • #4
        Can't connect at all now

        Ok,
        I have one computer.
        Since I reinstalled Liberty, the database doesnt' connect at all.
        Originally I just lost the Liberty Program. Order Management and POS launched, and had the database, and I processed ebay orders.

        When I couldn't add any inventory.. and I couldn't figure the connect to database stuff, I uninstalled, after backup, and reinstalled Liberty, and now I have no database access. and I can't find the ```````HKEY to copy and paste keys or check them. ANd I don't see how to performa or find "a named instance installation of MS SQL Server... named "server/Liberty".

        I just left a message on the tech support line, as I really need to figure this out this weekend. Any direction would be greatly appreciated, as always.

        suzonne

        Comment


        • #5
          Suzonne:

          The symptoms you've outlined point to various issues. One can't really "lose" the program, although, the program can be uninstalled. If POS and Order Manager launched, this means the database was there and more importantly, that SQL Server was running and allowing those applications to connect. This means, SQL was 100% fine and the Liberty Database Settings were 100% fine.

          If one program - i.e. Liberty/RWD - couldn't launch, this typically means a security application has blocked RWD.exe from running. It really (and I'm not being silly here) doesn't make sense, that RWPOS and RWOrderMngr would launch, yet RWD.exe would generate an "Unable to connect to database" error.

          All of the things you mentioned toward the end of your post - e.g. creating a named instance, etc. - aren't done by you. Rather, the application installs and configures SQL Server this way. We outline the different installation methods on our forum, as, well, they are different. It's important that one knows the differences between our installer pre-summer 2008 vs. the one we use now.

          In the end, if one fully uninstalls Liberty, reinstalls using our download or CD, restores the database and then finally, installs the latest update, all will go according to plan. If anything other than those steps has transpired, a variety of issues will arise.

          Hopefully your call to Support reveals more about the issue and comes with a resolution. If you can, reply back and let us know what the end results were!
          Resaleworld Support

          ***Don't forget to search the forum first! There might already be a post that resolves your issue!***

          Comment


          • #6
            Access Violation on one Client RWPOS

            I have replaced one of my computers. I am able to open up and connect to Liberty, yet when I try to open POS, I get this "Access Violation 004A5D28 in module RWPOS.exe address 0000004C. I checked my firewall settings and even disabled the entire firewall and still get the same message. I've searched and read all I could find on the message boards..is there anything else you suggest I can try?
            Adelle
            Adelle Daniels
            Children's Exchange
            www.children-exchange.com
            Remember who you wanted to be?

            Comment


            • #7
              If the versions do not match you will often get that error message. The nerdy reason for the Access Violation error: the POS (and inventory module, though that can be a bit more forgiving and not completely crash) is expecting to see certain fields in the database. If the POS is newer than the rest of the your systems, and subsequently the database itself, then it will be expecting values that do not exist. So the 'access violation' in this case is literally; the POS is trying to Access a field that does not exist.

              To confirm if this is the issue, go to Help >> About in the POS on the machine in question and then on another one that does not experience the issue. If they do not match, then this would be the reason why

              The easiest way to remedy it, if this is in fact the reason, would be to run the latest update on all machines. This will ensure the database is up to date as well as all the programs on all machines.

              Occasionally even an update wont quite go as planned (we are still running on Windows and we all know how stable that is) and even though the version may say 3.6a, it isnt quite 100%. Re-running the update on that machine will help to remedy it.

              Give that a shot and let us know!
              Jason Zander
              Resaleworld.com
              Software Developer
              (800) 785.4800

              Comment

              Working...
              X